SURF Service Disruption
Incident Report for MiraCosta College
Resolved
We will continue to monitor SURF throughout the day and will provide additional updates if the situation changes, but at this time we believe the service disruption is resolved. As always, we recommend restarting your web browser and clearing browser cache prior to logging back into SURF.
Posted May 21, 2024 - 09:02 PDT
Identified
ITS has identified what we believe is the root cause of the issue and service is now restored. The root cause was a network DNS configuration that was causing connection errors between servers. The configuration has been updated to address the issue and we are monitoring the system to ensure it remains stable.
Posted May 21, 2024 - 08:40 PDT
Investigating
We are currently experiencing a SURF service disruption, which is preventing students and employees from being able to access or login to SURF.

ITS staff are currently investigating the issue and working to restore service as quickly as possible. We will send additional updates as we have more information.
Posted May 21, 2024 - 08:36 PDT
This incident affected: SURF (Student Information System).